Home arrow static arrow Java Programming [Archive] - web.xml doesn't work
Warning: Creating default object from empty value in /www/htdocs/w008deb8/wiki/components/com_staticxt/staticxt.php on line 51
Java Programming [Archive] - web.xml doesn't work
This topic has 5 replies on 1 page.

Posts:7
Registered: 7/5/04
web.xml doesn't work  
Jul 6, 2004 8:21 AM



 
Hello,
Im trying to deploy a website with a WAR file. But when I upload my war file at my Hosting provider, it seems that my xml file isn't read(and is does work on my locale machine). I compile my war file with the following line.

jar -cvf c:\scarybarry.war -C c:\scarybarry .

Is there something that I have to do, to tell that that is a web.xml file that needs to be run?

Hopefully somebody can help me with this.
 

Posts:24,036
Registered: 2/3/03
Re: web.xml doesn't work  
Jul 6, 2004 8:28 AM (reply 1 of 5)



 
Are the contents of your WAR file configured correctly?
 

Posts:21,719
Registered: 98-02-20
Re: web.xml doesn't work  
Jul 6, 2004 8:33 AM (reply 2 of 5)



 
Hello,
Im trying to deploy a website with a WAR file. But
when I upload my war file at my Hosting provider, it
seems that my xml file isn't read(and is does work on
my locale machine). I compile my war file with the
following line.

jar -cvf c:\scarybarry.war -C c:\scarybarry .

Is there something that I have to do, to tell that
that is a web.xml file that needs to be run?

Hopefully somebody can help me with this.

You don't "run" a web.xml, so this is confusing to me. You deploy a WAR file, which will have a web.xml descriptor in its WEB-INF directory.

You don't say what "working" on your local machine looks like. Which servlet/JSP engine are you using? Which one does your ISP use?

My guess is that there's something wrong with your WAR file, your web.xml, or your app depends on having JAR files in a common place that aren't available. You've got a deployment problem to correct. No one here can help based on the little information you've provided.

%
 

Posts:5,627
Registered: 3/22/04
Re: web.xml doesn't work  
Jul 6, 2004 8:37 AM (reply 3 of 5)



 
You may have to "recycle" your web container, too. Sometimes our container acts weird after changes and the only hope is to recycle.

Good luck.
 

Posts:7
Registered: 7/5/04
Re: web.xml doesn't work  
Jul 6, 2004 10:35 AM (reply 4 of 5)



 
What kind of contents do you mean? Everything else deploys fine when I upload my WAR file.
 

Posts:7
Registered: 7/5/04
Re: web.xml doesn't work  
Jul 6, 2004 10:36 AM (reply 5 of 5)



 
What do you mean with recycle? It's not possible with my rights to restart my website.
 
This topic has 5 replies on 1 page.