Home arrow static arrow Java Programming [Archive] - Problem Running Java Program
Warning: Creating default object from empty value in /www/htdocs/w008deb8/wiki/components/com_staticxt/staticxt.php on line 51
Java Programming [Archive] - Problem Running Java Program
This topic has 1 reply on 1 page.

Posts:11
Registered: 6/14/04
Problem Running Java Program  
Jun 14, 2004 1:26 PM



 
When I go to run a java program I receive the following error:

Exception in thread "main" java.lang.NoClassDefFoundError: javax/xml/soap/SOAPException

Now, I know this is your standard classpath error but here are the complications:
The SOAPException directory is included in the classpath, so is the jar file (Explicitally). Furthermore, I have copied and pasted both the jar and the class into all the webapps directories in case it was looking for it on the localhost.

Any clues what I should checK?

I call java rom this command:

java -cp "C:
Program Files
Apache Software Foundation
Tomcat 5.0\\webapps\\axis\\WEB-INF
classes" com.sample.www.CecilDirect.MessageRequestorException in thread "main" java.lang.NoClassDefFoundError: javax/xml/soap/SOAPException

The SOAP classes look like they should be part of jaxrpc.jar but the SOAPException doesn't seem to be explicitally listed there.
 

Posts:134
Registered: 2/15/02
Re: Problem Running Java Program  
Jun 14, 2004 2:30 PM (reply 1 of 1)



 
you know that placing a jar into a directory is mostly not enough, you have to place the jar within the classpath too, like java -cp c:\jars\sax.jar MySaxProg

only calling with -cp c:\jars is NOT enough
 
This topic has 1 reply on 1 page.